SODE Registration Error

Home Forums Support SODE Registration Error

Topic Resolution: Resolved

This topic contains 5 replies, has 2 voices, and was last updated by  snowman9412 3 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2084

    snowman9412
    Participant

    Hi!

    I recently downloaded and installed SODE; however, when I click the register option on the manager menu, a new window opens up and says all path entries were “successfully” verified and the window says at the same time “Registration Error” I haven’t been able to see my purchased sceneries because this tool is needed for them to work… I have FSX: Steam Edition and yes, I also tried a beta version of SODE… After the error window shows up, it sends me back to the manager where it says it’s not registered and the option to click register again but the same error shows up no matter what I do.

    Here’s my log:

    [12:10:58.291] INFO : SODE Version 1.5.3
    [12:10:58.291] DEBUG : CommandLineArgs [1]: NONE!
    [12:10:58.291] FATAL : No Target Simulator Platform supplied! Shuting down…
    [12:10:58.291] INFO : Terminate SODE.

    I tried uninstalling and installing from scratch but nothing happens

    Thank you,
    Nicolas

    #2086

    snowman9412
    Participant

    On the Error window, it says exe.xml: XML is not type FS XML, everything else says successful though

    #2089

    12bPilot
    Keymaster

    Your exe.xml seems to be incorrect.
    Could you post the contents of it here?

    #2092

    snowman9412
    Participant

    Sure! Thank you for your help!

    Here are the contents of my exe.xml file on this folder location: C:\Users\snowm\AppData\Roaming\Microsoft\FSX

    (Just to make sure it’s the right path and file)
    Here is the content:

    <?xml version=”1.0″ encoding=”Windows-1252″?>

    <SimBase.Document Type=”SimConnect” version=”1,0″>
    <Descr>SimConnect</Descr>
    <Filename>SimConnect.xml</Filename>
    <Disabled>False</Disabled>
    <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>192.168.0.5</Address>
    <MaxClients>100</MaxClients>
    <Port>500</Port>
    <MaxRecvSize>8192</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
    </SimConnect.Comm>
    </SimBase.Document>

    #2093

    12bPilot
    Keymaster

    Thanks.

    That data does not belong in the exe.xml. These are the contents of a SimConnect.xml file, that configures the server -> https://msdn.microsoft.com/en-us/library/cc526983.aspx#TheSimConnectxmlfile

    In my case, I don’t have that file since I don’t run FS across multiple PC’s over a network.

    I’d delete that “wrong” exe.xml file and let the SODEPlatformManager create one automatically when you try to register SODE the next time.
    You will then notice that the Exe.xml is of Type=”Launch”, and not Type=”SimConnect”.

    Hope this resolves the issue.

    #2094

    snowman9412
    Participant

    It works now!

    Thank you very much for your help!!!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.